Miscellaneous Issues with Retr0n v3.0.2

Incident Report for SeismicCore

Update

We've identified and fixed an issue related to all discord links triggering our invite detection regex. We're continuing to monitor and fix various other issues and bugs in our v3.0.2 stable release.
Posted Nov 30, 2020 - 16:51 EST

Update

We're doing some maintenance to fix some of the issues in Retr0n 3.0.1 detailed in this report. Retr0n may be off and on for the duration of today.
Posted Nov 27, 2020 - 13:36 EST

Update

Additional issues have been found related to the `fortunecookie` command, and other inconsistencies regarding manual-mutes caused by caching issues
Posted Oct 21, 2020 - 07:38 EDT

Identified

We've identified multiple issues within our new 3.0.2 update. As stated in our previous report, Retr0n v3.0.2 was never fully meant to be supported on stable- and thus has some minor issues (mostly related to caching) that we have identified. We're looking for the root cause of these issues, and a method to fix them. Currently we have noticed the following:

- Logs generated by WebHooks (Join, Leave, Mod, Message, etc) will not show external emojis (Check emoji, etc)
- Join/Leave logs will often show no data for a member, will all values as `null` or `undefined`, caused by caching issues
- Some other very minor errors caused by caching
- Stats not sending over IPC to SeismicCore API (Stats not showing on site)
- Resction roles will create and store successfully, but Retr0n will remove its own reaction upon creation

If you're aware of any other issues besides these, PLEASE REPORT THEM! You can do so on our support guild, or at retr0n@smc.wtf. We're going to continue monitoring any effects of our 3.0.2 release, and fix any issues accordingly. All shards are working, online, etc- however they're having degraded performances in the areas mentioned above. Please be patient as we solve these issues!
Posted Oct 21, 2020 - 07:11 EDT
This incident affects: SeismicCore API and Retr0n Cluster0 (Shard 0, Shard 1, Shard 2, Shard 3).